mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Schelter <>
Subject Re: cardinality vs size
Date Sat, 12 Feb 2011 11:03:37 GMT
You're right, I forgot about that. We'd have to rename Vector.size() to 
Vector.dimension() to be consistent... And maybe Matrix.size() too?

Makes the refactoring a little bit more complicated. I think we should 
also keep Vector.size() and Matrix.size() as deprecated methods for a 
little time so we don't break any uncommitted patches.

What do you think?


On 12.02.2011 03:29, Ted Dunning wrote:
> It's a great idea.
> Changing any accessor names is a bit of a bigger deal, but still
> probably a good idea if we get consensus.
> On Fri, Feb 11, 2011 at 4:46 PM, Sebastian Schelter <
> <>> wrote:
>     Any objections to that? I'd go for a quick refactoring without a
>     jira if no one objects.

View raw message