mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Schelter <...@apache.org>
Subject Re: cardinality vs size
Date Fri, 11 Feb 2011 18:13:24 GMT
Maybe we should rename them to something like dimension and 
initialCapacity then?

--sebastian

On 11.02.2011 18:49, Weishung Chung wrote:
> Thanks a lot for the explanation. This really helps me out :)
>
> On Fri, Feb 11, 2011 at 11:38 AM, Ted Dunning<ted.dunning@gmail.com>  wrote:
>
>> Argh!
>>
>> This is a really confusing API.
>>
>> Cardinality is the dimension of the vector.
>>
>> Size is the number of storage elements that you want to have in the vector
>> initially, much in the style of ArrayList where you specify how many
>> elements to pre-allocate.
>>
>> On Fri, Feb 11, 2011 at 8:33 AM, Weishung Chung<weishung@gmail.com>
>> wrote:
>>
>>> Is cardinality the original size of the vector including zeros and size
>> is
>>> the number of nonzeros in the vector?
>>> I am referring to
>>>
>>>   public RandomAccessSparseVector(int cardinality, int size)
>>>
>>> Thank you :)
>>>


Mime
View raw message