mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From deneche abdelhakim <a_dene...@yahoo.fr>
Subject Re: Re : Help with Installation Instructions
Date Tue, 09 Jun 2009 08:49:24 GMT

> I do see CDInfosToolTest failing too:

Yeah the code is definitely buggy, I posted a patch that should (I hope) solve this issue.
The patch is available here: 

https://issues.apache.org/jira/browse/MAHOUT-113 

--- En date de : Mar 9.6.09, Sean Owen <srowen@gmail.com> a écrit :

> De: Sean Owen <srowen@gmail.com>
> Objet: Re: Re : Help with Installation Instructions
> À: mahout-user@lucene.apache.org
> Date: Mardi 9 Juin 2009, 9h47
> LoadTest is my department. Do you
> have any stack trace or other
> output? It would under core/target/surefire-reports.
> Normally it only
> fails from running too slowly, but, perhaps it hit some
> other bug.
> FWIW it runs normally for me locally.
> 
> I do see CDInfosToolTest failing too:
> 
> junit.framework.AssertionFailedError:
> expected:&lt;48&gt; but was:&lt;45&gt;
>         at
> junit.framework.Assert.fail(Assert.java:47)
>         at
> junit.framework.Assert.failNotEquals(Assert.java:280)
>         at
> junit.framework.Assert.assertEquals(Assert.java:64)
>         at
> junit.framework.Assert.assertEquals(Assert.java:198)
>         at
> junit.framework.Assert.assertEquals(Assert.java:204)
>         at
> org.apache.mahout.ga.watchmaker.cd.tool.CDInfosToolTest.testGatherInfos(CDInfosToolTest.java:206)
> 
> 
> On Tue, Jun 9, 2009 at 3:15 AM, J Cabb<joe.cabb@gmail.com>
> wrote:
> > Thank you very much for the quick response.  I
> followed the instructions
> > below.  I assumed the basic issue was to back up to
> the early point in the
> > instructions where you would run install from trunk.
>  I ran into the same
> > error at the same point.
> >
> > I checked against  https://issues.apache.org/jira/browse/MAHOUT-113 and
> now
> > it is the LoadTest that is failing instead of
> CDInfosToolTest.
> >
> > cd to {MAHOUT-ROOT}/trunk
> > mvn clean install --> [Build Successful]
> > cd core
> > mvn compile --> [Build Successful]
> > mvn install --> [Build failure]
> >
> > Test- Failed
> > Running org.apache.mahout.cf.taste.impl.LoadTest
> > Tests run: 3, Failures: 1, Errors: 0, Skipped: 0, Time
> elapsed: 311.442 sec
> > <<< FAILURE!
> >
> > cd ../examples
> > mvn compile  --> [Build Failure]
> >
> > I receive the same error about the missing artifact:
> >
> >
> > Missing:
> > ----------
> > 1) org.apache.mahout:mahout-core:jar:0.2-SNAPSHOT
> >
> >  Try downloading the file manually from the project
> website.
> >
> >  Then, install it using the command:
> >      mvn install:install-file
> -DgroupId=org.apache.mahout
> > -DartifactId=mahout-core -Dversion=0.2-SNAPSHOT
> -Dpackaging=jar
> > -Dfile=/path/to/file
> >
> >  Alternatively, if you host your own repository you
> can deploy the file
> > there:
> >      mvn deploy:deploy-file
> -DgroupId=org.apache.mahout
> > -DartifactId=mahout-core -Dversion=0.2-SNAPSHOT
> -Dpackaging=jar
> > -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
> >
> >  Path to dependency:
> >      1)
> org.apache.mahout:mahout-examples:jar:0.2-SNAPSHOT
> >      2)
> org.apache.mahout:mahout-core:jar:0.2-SNAPSHOT
> >
> > ----------
> > 1 required artifact is missing.
> >
> > for artifact:
> >  org.apache.mahout:mahout-examples:jar:0.2-SNAPSHOT
> >
> > from the specified remote repositories:
> >  Apache snapshots (http://people.apache.org/maven-snapshot-repository),
> >  maven2-repository.dev.java.net (http://download.java.net/maven/2),
> >  central (http://repo1.maven.org/maven2)
> >
> >
> >
> > Again, thank you for any help.
> >
> > Joe
> >
> 


      

Mime
View raw message