mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <sro...@gmail.com>
Subject Re: mahout for news recommendation?
Date Mon, 06 Apr 2009 11:56:19 GMT
> Great, thanks! I forgot to mention that the Requirements section lists J2SE
> 5.0, but actually 6.0 is required (BayesClassifier.java uses a
> java.util.Deque, for instance).

Yeah while the CF part doesn't use Java 6 classes it does use
@Override on interface methods now. It really should say Java 6 now.


> For sure. On that note, http://lucene.apache.org/mahout/releases.html should
> also be updated to link to some tarballs or something no?

Yes once there is a first release, indeed.


> - After obtaining a compatible version of mvn (2.0.10), I had to
> "export JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home"
> to get mvn -version to report "Java version: 1.6.0_07" rather than 1.5.0_16.
> The mvn install step will fail if it's not using java 1.6.

I feel like this is controlled on Macs by a little Java utility under
Applications > Utilities. Same effect. Indeed this needs to be
mentioned along with the Maven note.

Mime
View raw message