mahout-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAHOUT-2023) Drivers broken, scopt classes not found
Date Tue, 05 Dec 2017 19:28:00 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-2023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16279090#comment-16279090
] 

ASF GitHub Bot commented on MAHOUT-2023:
----------------------------------------

Github user pferrel commented on the issue:

    https://github.com/apache/mahout/pull/353
  
    The fix doesn’t seem to be working for me. what am I doing wrong?
    
    @rawkintrevo I 
    1) pulled your mahout-2023 branch
    2) `./buildtools/change-scala-version.sh 2.11`
    3) `mvn clean install -Pscala-2.11,spark-2.1`
    4) `jar tf mahout-spark_2.11-0.13.1-SNAPSHOT-dependency-reduced.jar | grep scopt`
    
    and get nothing, it's not going into the dependency-reduced.jar. 
    What am I doing wrong? (edited)
    
    
    [10:34] 
    also `mahout spark-itemsimilarity` reports a missing scopt as you'd expect
    
    
    [10:36] 
    This is what the `dependency-reduced.xml` looks like:
    ```      <includes>
            <!-- guava only included to get Preconditions in mahout-math and mahout-hdfs
-->
            <include>com.google.guava:guava</include>
            <include>com.github.scopt:scopt_${scala.compat.version}</include>
            <include>com.tdunning:t-digest</include>
            <include>org.apache.commons:commons-math3</include>
            <include>it.unimi.dsi:fastutil</include>
            <include>org.bytedeco:javacpp</include>
          </includes>
    ```
    
    
    [10:37] 
    after `./buildtools/change-scala-version.sh 2.11`
    
    
    [10:38] 
    does that script need to hit `dependency-reduced.xml`?


> Drivers broken, scopt classes not found
> ---------------------------------------
>
>                 Key: MAHOUT-2023
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-2023
>             Project: Mahout
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.13.1
>         Environment: any
>            Reporter: Pat Ferrel
>            Assignee: Trevor Grant
>            Priority: Blocker
>             Fix For: 0.13.1
>
>
> Type `mahout spark-itemsimilarity` after Mahout is installed properly and you get a fatal
exception due to missing scopt classes.
> Probably a build issue related to incorrect versions of scopt being looked for.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message