mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Musselman <andrew.mussel...@gmail.com>
Subject Re: [VOTE] Apache Mahout 0.13.0 Release Candidate
Date Sat, 15 Apr 2017 04:09:18 GMT
Cancelling this vote, one more coming out shortly.

On Fri, Apr 14, 2017 at 7:38 PM, Andrew Musselman <
andrew.musselman@gmail.com> wrote:

> Yeah I ripped it out today.
>
> Can put it back, or we can have this patch in the release notes and get a
> .1 release out in a couple weeks.
>
> I'm eager to ship this, if that would work let me know.
>
> On Fri, Apr 14, 2017 at 6:39 PM Andrew Palumbo <ap.dev@outlook.com> wrote:
>
>> replacing the
>>
>>
>> ${project.version}
>>
>> In the block:
>>
>>
>> <dependency>
>>   <groupId>org.apache.mahout</groupId>
>>   <artifactId>mahout-native-viennacl-omp_${scala.compat.
>> version}</artifactId>
>>   <version>${project.version}</version>
>> </dependency>
>>
>> of distribution/pom.xml seems to fix this error.  (for the OpenMp build
>> at least)
>>
>>
>>  I'm not sure how it was left out- the last commit before the release
>> commits:
>>
>>
>> https://github.com/apache/mahout/commit/059226746276a263f85d5c81d81731
>> 23ce81d45d
>>
>>
>> adds it back in after experimenting with its removal.  but after the
>> release commits it is missing again.
>>
>>
>> Or It possibly was only replaced in one profile, not both.
>>
>>
>>
>> ________________________________
>> From: Andrew Palumbo <ap.dev@outlook.com>
>> Sent: Friday, April 14, 2017 9:09:39 PM
>> To: dev@mahout.apache.org
>> Subject: Re: [VOTE] Apache Mahout 0.13.0 Release Candidate
>>
>>
>> I will continue looking.
>>
>> ________________________________
>> From: Andrew Palumbo <ap.dev@outlook.com>
>> Sent: Friday, April 14, 2017 9:09:06 PM
>> To: dev@mahout.apache.org
>> Subject: Re: [VOTE] Apache Mahout 0.13.0 Release Candidate
>>
>>
>> Tested the binary build and the src build with:
>>
>>
>> mvn clean install -Pviennacl -Phadoop2 -DskipTests.
>>
>>
>> Everything built and tested as expected.
>>
>>
>> However when building for OpenMP:
>>
>>
>> mvn clean install -Pviennacl -Phadoop2 -DskipTests && mvn test
>>
>>
>> the build failed with:
>>
>>
>> $  mvn clean install -Pviennacl-omp -Phadoop2 -DskipTests && mvn test
>> [INFO] Scanning for projects...
>> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [ERROR] 'dependencies.dependency.version' for org.apache.mahout:mahout-native-viennacl-omp_2.10:jar
>> is missing. @ org.apache.mahout:apache-mahout-distribution:[unknown-version],
>> /home/andy/sandbox/apache-mahout-distribution-0.13.0/distribution/pom.xml,
>> line 156, column 21
>> [WARNING] 'artifactId' contains an expression but should be a constant. @
>> org.apache.mahout:mahout-math-scala_${scala.compat.version}:[unknown-version],
>> /home/andy/sandbox/apache-mahout-distribution-0.13.0/math-scala/pom.xml,
>> line 30, column 15
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] 'artifactId' contains an expression but should be a constant. @
>> org.apache.mahout:mahout-spark_${scala.compat.version}:[unknown-version],
>> /home/andy/sandbox/apache-mahout-distribution-0.13.0/spark/pom.xml, line
>> 30, column 15
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] 'artifactId' contains an expression but should be a constant. @
>> org.apache.mahout:mahout-h2o_${scala.compat.version}:[unknown-version],
>> /home/andy/sandbox/apache-mahout-distribution-0.13.0/h2o/pom.xml, line
>> 30, column 15
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] 'artifactId' contains an expression but should be a constant. @
>> org.apache.mahout:mahout-native-viennacl-omp_${scala.
>> compat.version}:[unknown-version], /home/andy/sandbox/apache-
>> mahout-distribution-0.13.0/viennacl-omp/pom.xml, line 30, column 15
>> [WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but
>> found duplicate declaration of plugin org.codehaus.mojo:exec-maven-plugin
>> @ org.apache.mahout:mahout-native-viennacl-omp_${scala.
>> compat.version}:[unknown-version], /home/andy/sandbox/apache-
>> mahout-distribution-0.13.0/viennacl-omp/pom.xml, line 179, column 15
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>> [WARNING] The expression ${version} is deprecated. Please use
>> ${project.version} instead. @
>>  @
>> [ERROR] The build could not read 1 project -> [Help 1]
>> [ERROR]
>> [ERROR]   The project org.apache.mahout:apache-mahout-distribution:0.13.0
>> (/home/andy/sandbox/apache-mahout-distribution-0.13.0/distribution/pom.xml)
>> has 1 error
>> [ERROR]     'dependencies.dependency.version' for
>> org.apache.mahout:mahout-native-viennacl-omp_2.10:jar is missing. @
>> org.apache.mahout:apache-mahout-distribution:[unknown-version],
>> /home/andy/sandbox/apache-mahout-distribution-0.13.0/distribution/pom.xml,
>> line 156, column 21
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with the
>> -e switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please read the following articles:
>> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
>> ProjectBuildingException
>>
>>
>> This must be why we had {project.version} included.
>>
>> ________________________________
>> From: Andrew Musselman <andrew.musselman@gmail.com>
>> Sent: Friday, April 14, 2017 4:49:34 PM
>> To: user@mahout.apache.org; dev@mahout.apache.org
>> Subject: [VOTE] Apache Mahout 0.13.0 Release Candidate
>>
>> This is the vote for release 0.13.0 of Apache Mahout.
>>
>> The vote will be going for at least 72 hours and will be closed on Monday,
>> April 17th, 2017 or once there are at least 3 PMC +1 binding votes
>> (whichever
>> occurs earlier).  Please download, test and vote with
>>
>> [ ] +1, accept RC as the official 0.13.0 release of Apache Mahout
>> [ ] +0, I don't care either way,
>> [ ] -1, do not accept RC as the official 0.13.0 release of Apache Mahout,
>> because...
>>
>> Note if you get a segfault running the binary version you may need to
>> build
>> from source with the viennacl profile like so:
>>
>> mvn clean install -Pviennacl,hadoop2 -DskipTests=true
>>
>> Maven staging repo:
>>
>> https://repository.apache.org/content/repositories/
>> orgapachemahout-1043/org/apache/mahout/apache-mahout-distribution/0.13.0
>>
>> The git tag to be voted upon is mahout-0.13.0.
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message