mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trevor Grant (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAHOUT-1894) Add support for Spark 2x backend
Date Thu, 02 Feb 2017 02:33:52 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-1894?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15849309#comment-15849309
] 

Trevor Grant commented on MAHOUT-1894:
--------------------------------------

When building Mahout against spark 2.0.2 I get one warning
```
[WARNING] /home/rawkintrevo/gits/mahout-local/spark/src/test/scala/org/apache/mahout/sparkbindings/drm/DrmLikeSuite.scala:127:
warning: constructor SQLContext in class SQLContext is deprecated: Use SparkSession.builder
instead
[WARNING]     val sqlContext= new org.apache.spark.sql.SQLContext(sc)
```

And then in the tests a lot of whining about 
```
Exception encountered when invoking run on a nested suite - requirement failed: MAHOUT_HOME
is required to spawn mahout-based spark jobs *** ABORTED ***
  java.lang.IllegalArgumentException: requirement failed: MAHOUT_HOME is required to spawn
mahout-based spark jobs
```

> Add support for Spark 2x backend
> --------------------------------
>
>                 Key: MAHOUT-1894
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-1894
>             Project: Mahout
>          Issue Type: Task
>          Components: spark
>    Affects Versions: 0.13.0
>            Reporter: Suneel Marthi
>            Priority: Critical
>             Fix For: 1.0.0, 0.13.0, 0.14.0
>
>
> add support for Spark 2.x as backend execution engine.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message