mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Ostrikov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAHOUT-1329) Mahout for hadoop 2
Date Wed, 30 Apr 2014 17:02:21 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-1329?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13985747#comment-13985747
] 

Alexander Ostrikov commented on MAHOUT-1329:
--------------------------------------------

Hi, 
I'm trying to run Mahout 0.9 by Oozie on hdp2.1 (hadoop 2.4).
trainnb fails with Exception in thread "main" java.lang.IncompatibleClassChangeError: Found
interface org.apache.hadoop.mapreduce.JobContext, but class was expected.
I compiled Mahour-trunk downloaded from here https://github.com/apache/mahout/archive/trunk.zip
and compiled it with 
"mvn clean install -Dhadoop2 -Dhadoop.2.version=2.4.0  -DskipTests=true".
Still getting the error...
Any idea what's wrong with it? Thanks!

> Mahout for hadoop 2
> -------------------
>
>                 Key: MAHOUT-1329
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-1329
>             Project: Mahout
>          Issue Type: Task
>          Components: build
>    Affects Versions: 0.9
>            Reporter: Sergey Svinarchuk
>            Assignee: Gokhan Capan
>              Labels: patch
>             Fix For: 1.0
>
>         Attachments: 1329-2.patch, 1329-3-additional.patch, 1329-3.patch, 1329.patch
>
>
> Update mahout for work with hadoop 2.X, targeting this for Mahout 1.0.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message