mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitriy Lyubimov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAHOUT-1412) Build warning due to multiple Scala versions
Date Wed, 05 Feb 2014 02:08:09 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-1412?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13891606#comment-13891606
] 

Dmitriy Lyubimov commented on MAHOUT-1412:
------------------------------------------

scalatest has not, and it seems does not build artifacts for 2.9.3 scala. 

There's an artifact for 2.9.2 and 2.10. They seem to imply they build only one artifact fit
for all the 2.9.whatever. 

Scala is mostly inttroduced to build mixed environment of in-core operations and Spark so
it tracks Spark versions of scala and scalatest. 

Spark just released 0.9.0 and scalatest just released 2.0 -- we can bump to these eventually

> Build warning due to multiple Scala versions
> --------------------------------------------
>
>                 Key: MAHOUT-1412
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-1412
>             Project: Mahout
>          Issue Type: Improvement
>    Affects Versions: 0.9
>            Reporter: Frank Scholten
>            Priority: Minor
>
> I see the following build warning:
> 22:42:07 [WARNING]  Expected all dependencies to require Scala version: 2.9.3
> 22:42:07 [WARNING]  org.apache.mahout:mahout-math-scala:1.0-SNAPSHOT requires scala version:
2.9.3
> 22:42:07 [WARNING]  org.scalatest:scalatest_2.9.2:1.9.1 requires scala version: 2.9.2
> 22:42:07 [WARNING] Multiple versions of scala libraries detected!
> Which version should we use?



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message