mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Prasanna Kumar (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
Date Sat, 05 Nov 2011 03:45:52 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13144550#comment-13144550
] 

Joe Prasanna Kumar commented on MAHOUT-868:
-------------------------------------------

How about this
current -> build-cluster-syntheticcontrol.sh : proposed -> cluster-syntheticcontrol.sh
current -> build-asf-email.sh : proposed -> recommend-classify-cluster-asf-email.sh
current -> build-reuters.sh : proposed -> cluster-reuters.sh
current -> factorize-movielens-1M.sh : proposed -> recommend-movielens-1M.sh

the format being <recommend or cluster or classify>-<dataset>.sh

The build-asf-email.sh and factorize-movielens-1M.sh doesnt have code to download the dataset.
I think itz better if we can modify the script to download the dataset. Shud I proceed modifying
the scripts and upload a patch ?

reg
Joe

                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate
them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest
we keep them around for a release or two and have them simply call the new one, along with
printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message