mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anatoliy Kats (Commented) (JIRA)" <>
Subject [jira] [Commented] (MAHOUT-896) Improve readability of AbstractDifferenceRecommenderEvaluator class
Date Fri, 25 Nov 2011 16:25:40 GMT


Anatoliy Kats commented on MAHOUT-896:

Patch submitted.  The method name processUser is uninformative, since the word 'process' can
refer to anything.  The original names for the parameters are also confusing:  it is not clear
that trainingUsers and testingUserPrefs refer to the same kinds of items.  The word 'Pref'
is, ahem, preferable, since the Preference class includes the User ID, Item ID, and Preference
Value.  So, I renamed all the variables to use that term only.

What do you think?
> Improve readability of AbstractDifferenceRecommenderEvaluator class
> -------------------------------------------------------------------
>                 Key: MAHOUT-896
>                 URL:
>             Project: Mahout
>          Issue Type: Improvement
>          Components: Collaborative Filtering
>    Affects Versions: 0.6
>            Reporter: Anatoliy Kats
>            Assignee: Sean Owen
>            Priority: Trivial
>              Labels: newbie
>         Attachments: MAHOUT-896.patch
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
> Change the variable and private method names so that they are internally consistent,
and their purpose is more clear.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message