mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Drew Farris (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAHOUT-427) $MAHOUT_HOME/examples/bin/build-reuters.sh doesn't run successfully because of classpath issues related to the -core argument
Date Wed, 07 Jul 2010 01:51:50 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12885774#action_12885774
] 

Drew Farris commented on MAHOUT-427:
------------------------------------

I wasn't able to reproduce this issue following the wiki instructions (up to step 9, running
the hadoop cluster in single-node mode), leaving out the mvn install on the examples directory.

Is there any chance you could try a 'mvn clean install' (from the base directory) with your
working copy to see if it still refuses to build an examples job? Otherwise, could you check
out a fresh copy and give that a try?

Somewhat unrelated but worth noting: when I did run build-reuters,sh, k-means converged after
8 iterations instead of 10 and thus the clusterdump step did not complete successfully. When
you finally managed to get the examples to run, what was the highest numbered clusters-* directory
in examples/bin/work/reuters-kmeans


> $MAHOUT_HOME/examples/bin/build-reuters.sh doesn't run successfully because of classpath
issues related to the -core argument
> -----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-427
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-427
>             Project: Mahout
>          Issue Type: Bug
>    Affects Versions: 0.4
>         Environment: Hadoop installation on EC2 as described here - https://cwiki.apache.org/MAHOUT/mahoutec2.html
>            Reporter: Peter Goldstein
>
> Once I resolved issue MAHOUT-426 , I was still not able to run the ./examples/bin/build-reuters.sh
script without errors  These were ClassNotFoundExceptions, indicating a problem with the classpath.
 
> The issue appears to be related to the "-core" argument, which controls the classpath.
 Placing '-core' as the first argument to the individual $MAHOUT_HOME/bin/mahout calls in
the script solved the issue, but I'm not sure it was the correct solution.  It's unclear to
me what the '-core' argument is supposed to signify.
> Can someone shed some light on this, and tell me whether this is the correct solution
to the problem?  And if not, what is the correct solution to this classpath issue.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message