mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shannon Quinn <squ...@gatech.edu>
Subject Re: Fixing broken import paths in Eclipse
Date Thu, 03 Jun 2010 03:53:28 GMT
Hi Drew,

Thanks for the direction; unfortunately I only made it as far as step 4
before receiving the following error:

[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] An Ant BuildException has occured: The following error occurred while
executing this line:
/mahout/eclipse/setup-eclipse-workspace.xml:33: Warning: Could not find file
/mahout/etc/mahout-checkstyle.xml to copy.

The file it references is indeed missing.

I'm going to keep fiddling with it, perhaps stumble upon something, but
wanted to give feedback as soon as I could. Thank you!

Shannon

On Wed, Jun 2, 2010 at 11:08 PM, Drew Farris <drew.farris@gmail.com> wrote:

> Hi Shannon,
>
> A while back Benson spent some time working towards making it easier to set
> up the mahout projects in eclipse. He documented his approach in the thread
> here;
>
>
> http://www.lucidimagination.com/search/document/f97cfdd1d2543316/progress_with_eclipse#a5da14bd5d1adceb
>
> Perhaps you could give that I try and report back with your results? I
> recently had some success setting up my environment using this approach.
>
> HTH,
>
> - Drew
>
> On Wed, Jun 2, 2010 at 9:24 PM, Shannon Quinn <squinn@gatech.edu> wrote:
>
> > Hi all,
> >
> > I apologize for yet another silly question, but seeing as how it'd be
> nice
> > if my code recognized import paths, I request your assistance.
> >
> > Here's my workbench:
> > http://spectrallyclustered.files.wordpress.com/2010/06/eclipse.jpg
> >
> > I issued the "mvn eclipse:eclipse" command after building the project,
> and
> > at the root level I could import "mahout", or navigate one level deeper
> and
> > import each module individually, though doing so still created the same
> > problem. Eclipse isn't seeing the Mahout dependencies (though I'm also
> not
> > sure how to point it to Hadoop). Thanks again for the assistance :)
> >
> > Shannon
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message