mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Mannix <jake.man...@gmail.com>
Subject Re: [jira] Commented: (MAHOUT-379) SequentialAccessSparseVector.equals does not agree with AbstractVector.equivalent
Date Sun, 18 Apr 2010 15:41:21 GMT
Which one is "this"?  Wrapping Vector impls into a
NamedVector/LabeledVector,
or seeing if we even need the label *inside* of the Vector itself, and
instead
just having those live in the "key" part of the key-value pair in hadoop,
like
DistributedRowMatrix has it?

  -jake

On Sun, Apr 18, 2010 at 3:44 AM, Sean Owen <srowen@gmail.com> wrote:

> Yeah why don't I have a crack at this. The change as it stands is
> already too big for what it is (though I believe they're good
> changes.) Then we look at more changes, and sounds like there are
> several ideas for streamlining vectors, which is a great thing to
> think about at this early stage.
>
> On Sun, Apr 18, 2010 at 12:54 AM, Ted Dunning <ted.dunning@gmail.com>
> wrote:
> > How about this alternative:
> >
> > NamedVector: {Vector: wrapped, String: name}
> > Vector: AbstractVector
> > AbstractVector: DenseVector | SequentialSparseVector | HashSparseVector
> >
> > This avoids the multiplicative explosion of vector types.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message