mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <>
Subject [jira] Commented: (MAHOUT-350) add one "JobName" and reduceNumber parameter to
Date Wed, 31 Mar 2010 16:31:27 GMT


Sean Owen commented on MAHOUT-350:

Hmm, I don't understand that. AbstractJob.class and ItemIDIndexMapper.class are in the same
.jar file. There is only one .jar, with both, so both ought to end up selecting the same .jar
file. I'd rather specify the Mapper class instead just because maybe someday someone subclasses
AbstractJob, puts the implementation in a different jar, and then this line won't work.

I can set it to AbstractJob.class for now... but still think there's something wrong here.

About the other arguemnts, yes, I agree there should be an option.
I was looking to see how Hadoop accepts arguments like "-Dmapred...." on the command line.
I can't find it parsing these anywhere. So I don't know this exists.

So I can now start adding custom parameters for things like this.

> add  one "JobName" and reduceNumber parameter to
> ------------------------------------------------------------------------------------------------------
>                 Key: MAHOUT-350
>                 URL:
>             Project: Mahout
>          Issue Type: Improvement
>          Components: Collaborative Filtering
>    Affects Versions: 0.4
>            Reporter: Hui Wen Han
>            Priority: Minor
>         Attachments: screenshot-1.jpg
> Can add one  "JobName" parameter to
> if there's a lot of RecommenderJob,it's hard to distinguish  those jobs.
> also RecommenderJob has four sub jobs (or phase ) ,can add sub-job name to those phase
> Because RecommenderJob has not setNumReduceTasks ,it seems that the performance is not
good in reduce phase.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message