mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dawid Weiss (JIRA)" <j...@apache.org>
Subject [jira] Updated: (MAHOUT-264) Make mahout-math compatible with Java 1.5 (bytecode and standard library).
Date Wed, 20 Jan 2010 19:04:54 GMT

     [ https://issues.apache.org/jira/browse/MAHOUT-264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dawid Weiss updated MAHOUT-264:
-------------------------------

    Attachment: MAHOUT-264.patch

As far a I can tell, this patch solves this issue. You still _must_ compile with a java 1.6
compiler (@Override annotations on interface methods), but the resulting bytecode is 1.5 compatible
and does not use 1.6-specific API.

> Make mahout-math compatible with Java 1.5 (bytecode and standard library).
> --------------------------------------------------------------------------
>
>                 Key: MAHOUT-264
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-264
>             Project: Mahout
>          Issue Type: Wish
>          Components: Math
>            Reporter: Dawid Weiss
>            Assignee: Benson Margulies
>            Priority: Minor
>         Attachments: MAHOUT-264.patch
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message