mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Drew Farris (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAHOUT-225) Rename mahout-matrix to mahout-math
Date Tue, 15 Dec 2009 16:42:18 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-225?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12790811#action_12790811
] 

Drew Farris commented on MAHOUT-225:
------------------------------------

Thanks Sean.

> Rename mahout-matrix to mahout-math
> -----------------------------------
>
>                 Key: MAHOUT-225
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-225
>             Project: Mahout
>          Issue Type: Improvement
>          Components: Matrix
>    Affects Versions: 0.2
>            Reporter: Drew Farris
>            Assignee: Drew Farris
>             Fix For: 0.3
>
>         Attachments: mahout-matrix-rename.patch
>
>
> Per discussion on the dev list, this patch renames:
> o.a.m.matrix -> o.a.m.math
> o.a.m.jet -> o.a.m.math.jet
> Things currently under o.a.m.matrix would retain their existing names,
> with s/matrix/math, for example:
> o.a.m.math.bitvector
> o.a.m.math.buffer
> o.a.m.math.function
> o.a.m.math.list
> o.a.m.math.map
> o.a.m.math.matrix
> The maven submodule is changed from mahout-matrix to mahout-math
> Apply this patch with -E to delete empty files, and then 'svn delete matrix' and 'svn
add math' -- I couldn't figure out how to get patch to set that up automatically.
> Verified that patch applies cleanly to r890796, build completes and unit tests work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message