mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAHOUT-179) Taste Demo Help
Date Wed, 23 Sep 2009 13:49:16 GMT

    [ https://issues.apache.org/jira/browse/MAHOUT-179?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12758704#action_12758704
] 

Sean Owen commented on MAHOUT-179:
----------------------------------

So I just tried this from a clean installation of the project.

I ran into one issue: the web app needs to include uncommons-math as a dependency. I fixed
that and committed my change just now. So, I imagine you perhaps also ran into the same problem
-- did you see a big stack trace on startup? that would cause the server to not respond.

Anyway once that was fixed, I do now get recommendations at:

http://localhost:8080/RecommenderServlet?userID=1

(I have updated the documentation in SVN to reflect the right path)

Yes, you should find nothing at http://localhost:8080/. It really shouldn't unpack META-INF
but I guess the plugin does. WEB-INF would be hidden indeed as it is never served as files.

Given the above, is it still not working?

> Taste Demo Help
> ---------------
>
>                 Key: MAHOUT-179
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-179
>             Project: Mahout
>          Issue Type: Question
>          Components: Collaborative Filtering
>         Environment: win vista/cygwin
>            Reporter: Tamas Jambor
>            Priority: Minor
>
> hi there,
> I'm trying to run the taste demo, just downloaded the latest version of mahout. I compile
the whole thing (mvn install) and I create the package. everything runs smoothly, but in the
end it gives me this error:
> HTTP ERROR 404
> Problem accessing /mahout-taste-webapp/RecommenderServlet. Reason:
> NOT_FOUND
> i'm not really familiar with this enviroment but maybe the war file might create a library
'mahout-taste-webapp-0.1' instead of 'mahout-taste-webapp'?
> please help me out.
> thanks a lot,
> Tamas

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message