mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: mvn install error
Date Mon, 20 Jul 2009 13:32:14 GMT
Sean,

mvn install from the top should work. I would like to know if anyone  
else is suffering.

you could do a second checkout and a diff to see if you've ended up  
with a mess . on next plalr.

On Jul 20, 2009, at 9:15 AM, Sean Owen <srowen@gmail.com> wrote:

> (Flushing the repo amounts to deleting everything in ~/.m2/ ?)
>
> I updated to Maven 2.2.0. Same result when I ran 'mvn install' from
> the top. Running from within maven/, it did seem to correctly
> repopulate to repository*.
>
> But then, same result when running 'mvn install' from the top, or  
> core/.
>
> Let's break this down, since I really need it to work and perhaps
> there is reason to believe it is something to do with my installation,
> or repo, or approach.
>
> What is the right sequence of commands to build, in theory? begin with
> 'mvn install' from the top? or from core/?
>
> I am willing to just completely erase my SVN copy and try again, but
> can you guys also confirm this works if, say, you delete your repo and
> start again? I am no Maven maven but it seems to be missing
> 0.2-SNAPSHOT, which indeed, does not exist yet in the wild right? so
> it must be building and installing locally... but I see no local repo
> configured, or else, the part that builds and installs this artifact
> somehow depends on itself now?
>
> Another clue I suppose is that it worked before the last revision,
> does that help anyone?
>
>
> * Interestingly it did not download the slf4j dependency, so I can't
> build in the IDE. I wonder why that is special... and does that
> provide any clues to the issue above?
>
>
> On Mon, Jul 20, 2009 at 2:01 PM, Benson Margulies<bimargulies@gmail.com 
> > wrote:
>> Sean,
>>
>> Any of these should work fine, and appear to work fine for others.
>>
>> If you are not running 2.1.0, I'd recommend an upgrade. If you are,
>> I'd recommend flushing your local repository and seeing if things get
>> better.
>>
>> The structure here is a common one, so I don't have any idea why it  
>> is
>> misbehaving for you.
>>
>> --benson
>>
>>
>> On Mon, Jul 20, 2009 at 8:55 AM, Sean Owen<srowen@gmail.com> wrote:
>>> (Maven version is 2.1.0-M1 on a Mac)
>>>
>>> 'mvn install' succeeds from within the maven/ directory. But I see  
>>> the
>>> same result when then running this from core/, or the root,
>>> afterwards.
>>>
>>> What, in theory, is the 'right' way to build? which commands, from
>>> which dir? if I just want to generate a .jar with the library code.
>>>
>>> On Mon, Jul 20, 2009 at 1:51 PM, Benson Margulies<bimargulies@gmail.com 
>>> > wrote:
>>>> Sean,
>>>>
>>>> The core POM has a parent that looks for
>>>> org.apache.mahout:maven-parent:0.2-SNAPSHOT, with a relativePath of
>>>> ../maven.
>>>>
>>>> The maven-parent pom seems to be indeed defining
>>>>
>>>> org.apache.mahout:maven-parent:0.2-SNAPSHOT.
>>>>
>>>>  Does it work if you run maven in the 'maven' directory and then  
>>>> run
>>>> it from the core directory?
>>>>
>>>> I don't think you've mentioned your maven version yet.
>>>>
>>>> I sort of hope that Grant did the sanity test of removing his local
>>>> repo for org/apache/mahout before he committed this.
>>>
>>

Mime
View raw message