mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <sro...@gmail.com>
Subject Re: Mahout for 1.5 JVM
Date Mon, 09 Mar 2009 21:15:09 GMT
You need to compile with Java 6, and set source to "1.6" (er, is it
"6" and "5"? Ant accepts both and I bet Maven does too). The target is
indeed "1.5". Java 6 should be able to generate byte code for Java 5;
there is some chance though that the code or a dependency like Hadoop
uses a class or API introduced in Java 6. There weren't many of those
so some large subset of Mahout may indeed work on Java 5.

What error are you getting? that may point to the problem.


On Mon, Mar 9, 2009 at 9:04 PM, Grant Ingersoll <gsingers@apache.org> wrote:
> Mahout requires 1.6 due to Hadoop requiring 1.6.  You'd have to backport to
> an older version of Hadoop.
>
> At any rate, I think the maven stuff looks right.  Are you exporting a 1.5
> JVM JAVA_HOME?  I think Maven just uses JAVA_HOME to determine the JVM
> version.

Mime
View raw message