mahout-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Eastman <j...@windwardsolutions.com>
Subject Re: Re : @Override annotations
Date Thu, 22 Jan 2009 13:41:44 GMT
I was able to get past the compiler problems by switching the compliance 
level to Java 6, thanks Deneche. IIRC,  With Java 6.0, @Override *can* 
also be used if your method implements a method in a base interface. If 
this is the only 6.0 feature we are using it is a shame to preclude Java 
5 compilation for this alone.

Jeff


Sean Owen wrote:
> Yes I added them since we are officially requiring Java 6 -- right?
> that was the conclusion on a recent thread.
>
> On Thu, Jan 22, 2009 at 9:33 AM, deneche abdelhakim <a_deneche@yahoo.fr> wrote:
>   
>> When you say 1.5, you mean the 1.5 JDK (or JRE in the case of Eclipse) ?
>>
>> Because, I just tried to compile the Mahout trunk in Eclipse using JRE 1.5.0_11 (and
5.0 compliance level of course), and got 628 errors in core/src (I didn't check core/test
yet).
>>
>> The first 100 errors are as follows:
>> . 98 errors related to the @Override, for example:
>>
>>     
>
>
>   


Mime
View raw message