lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Wellnhofer <wellnho...@aevum.de>
Subject Re: [lucy-user] 0.6.0 appears to be broken for Perl
Date Fri, 07 Oct 2016 21:18:53 GMT

> On Oct 7, 2016, at 22:53 , Tilghman Lesher <tilghman@meg.abyt.es> wrote:
> 
>> What's the output of
>> 
>>    perl -MClownfish -le 'print $Clownfish::VERSION'
> 
> [tlesher@phpdev
> ~/ExternalPackages/apache-clownfish-0.6.0/runtime/perl]$ find
> /usr/local/lib/perl5/site_perl -name Clownfish.pm
> /usr/local/lib/perl5/site_perl/mach/5.20/Clownfish.pm
> [tlesher@phpdev
> ~/ExternalPackages/apache-clownfish-0.6.0/runtime/perl]$ perl
> -MClownfish -le 'print $Clownfish::VERSION'
> Can't locate loadable object for module Clownfish in @INC

So you’re running FreeBSD? There are some known build problems with 0.6.0 on BSD which will
be fixed shortly. You should be able to install Lucy 0.6.0 on BSD using the following pre-release
versions from CPAN:

https://cpan.metacpan.org/authors/id/N/NW/NWELLNHOF/Clownfish-CFC-0.6.0.tar.gz
https://cpan.metacpan.org/authors/id/N/NW/NWELLNHOF/Clownfish-0.6.0.3.tar.gz
https://cpan.metacpan.org/authors/id/N/NW/NWELLNHOF/Lucy-0.6.0_2.tar.gz

Or wait about two weeks for the 0.6.1 release.

Nick


Mime
View raw message