lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <mar...@rectangular.com>
Subject Re: [lucy-user] Sort Spec problem on Debian Jessie
Date Wed, 27 Jul 2016 20:57:09 GMT
On Wed, Jul 27, 2016 at 1:42 PM, Noe Fernandez <nf232@cornell.edu> wrote:
> Hi All,
>
> I got an error running Lucy::Search::SortSpec when I am working on a Debian jessie.
>
> The same code work fine on Debian Wheezy and OSX El Capitan.
>
> It is just a very simple script to search and sort the output from an index created from
a 3 columns tab delimited file. I do not think there is any problem in the code since it is
working on my mac computer (El Capitan) and in several Debian Wheezy VM and servers.
>
>
> The error only says:
>
> Invalid parameter: 'sort_spec'
>         cfish_XSBind_locate_args at xs/XSBind.c line 382
>
>
>
> Is there anything I could do to fix it?

This error indicates that a subroutine which does not take a parameter
called `sort_spec` is receiving it nonetheless.

The next step is identifying the location in the code where the
problem is occurring.  I suggest searching through your code for the
string `sort_spec`, or just using debug printing to hunt it down.

Once you find the call site where the problem is occurring, if it's
not obvious how to fix it, please send a snippet to this list
(stripped of any information you don't want published publicly) and
we'll take a look.

Marvin Humphrey

Mime
View raw message