lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noe Fernandez <nf...@cornell.edu>
Subject Re: [lucy-user] Sort Spec problem on Debian Jessie
Date Wed, 27 Jul 2016 21:35:29 GMT
Hi Marvin,

I attach a link to a zip file with an example of an index folder and the script I am using.
It worked on OSX El Capitan and Debian Wheezy

It crashed on Debian Jessie

perl search_corr_index.pl Manes.10G119800 example_index/

It should return

Manes.10G119800 Manes.01G265300 0.96
Manes.10G119800 Manes.11G147600 0.94
Manes.10G119800 Manes.01G109500 0.93
Manes.10G119800 Manes.07G142200 0.93
Manes.10G119800 Manes.11G133300 0.93
Manes.10G119800 Manes.01G217000 0.92
Manes.10G119800 Manes.04G147400 0.92
Manes.10G119800 Manes.05G157800 0.92
Manes.10G119800 Manes.06G083900 0.92
Manes.10G119800 Manes.08G121000 0.92
Manes.10G119800 Manes.09G050100 0.92
Manes.10G119800 Manes.13G128100 0.92
Manes.10G119800 Manes.02G100800 0.91
Manes.10G119800 Manes.02G119400 0.91
Manes.10G119800 Manes.03G016000 0.91
Manes.10G119800 Manes.04G043900 0.91
Manes.10G119800 Manes.06G141000 0.91
Manes.10G119800 Manes.09G120900 0.91
Manes.10G119800 Manes.10G031600 0.91
Manes.10G119800 Manes.11G131000 0.91



Thank you,
Noe

https://drive.google.com/open?id=0B5naznfIBi9peU5ZVzU4eDVNUDA




On Jul 27, 2016, at 4:57 PM, Marvin Humphrey <marvin@rectangular.com> wrote:

On Wed, Jul 27, 2016 at 1:42 PM, Noe Fernandez <nf232@cornell.edu<mailto:nf232@cornell.edu>>
wrote:
Hi All,

I got an error running Lucy::Search::SortSpec when I am working on a Debian jessie.

The same code work fine on Debian Wheezy and OSX El Capitan.

It is just a very simple script to search and sort the output from an index created from a
3 columns tab delimited file. I do not think there is any problem in the code since it is
working on my mac computer (El Capitan) and in several Debian Wheezy VM and servers.


The error only says:

Invalid parameter: 'sort_spec'
       cfish_XSBind_locate_args at xs/XSBind.c line 382



Is there anything I could do to fix it?

This error indicates that a subroutine which does not take a parameter
called `sort_spec` is receiving it nonetheless.

The next step is identifying the location in the code where the
problem is occurring.  I suggest searching through your code for the
string `sort_spec`, or just using debug printing to hunt it down.

Once you find the call site where the problem is occurring, if it's
not obvious how to fix it, please send a snippet to this list
(stripped of any information you don't want published publicly) and
we'll take a look.

Marvin Humphrey


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message