lucy-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Wellnhofer <wellnho...@aevum.de>
Subject Re: [lucy-user] Compiling Lucy 4.2 Strawberry 5.20
Date Mon, 30 Mar 2015 12:27:25 GMT
On 30/03/2015 13:11, Thomas den Braber wrote:
> I am compiling version 4.2 on Strawberry 5.20 64-bit on Windows 7.
>
> I first have successfully compiled Clownfish and the Clownfish ::CFC
> (version 4.2).
>
> When Compiling Lucy, first it starts to successful compile some modules but
> after a while there are these undefined references:

This is caused by a change in Strawberry Perl 5.20. The 5.20 release uses 
$Config{dlext} == 'xs.dll' which breaks the setup of our linker flags.

The following commit to Clownfish::CFC fixes the issue:

https://git-wip-us.apache.org/repos/asf?p=lucy-clownfish.git;a=commitdiff;h=6e16fc642830338beed22e9b1976e0585075f950

It will be part of the next release in the 0.4 series. In the meantime, you 
can apply the patch manually or use Strawberry Perl 5.18.

Nick


Mime
View raw message