lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Kurz <>
Subject Re: [lucy-dev] Clownfish String API
Date Thu, 22 Oct 2015 22:13:28 GMT
On Thu, Oct 22, 2015 at 2:57 PM, Marvin Humphrey <> wrote:
> I think `Skip_Whitespace` is the best option for forward skipping.  I can't
> think of a good option for moving backwards past any whitespace before the
> current iterator position.  It's not a common operation, though, and I can
> live with a suboptimal name.  `Skip_Prev_Whitespace` might be the clearest,
> since it can be contrasted with `Skip_Whitespace` -- and it's less
> gramatically awkward than `Recede_Whitespace`.

Hi Guys --

Perhaps consider the modifier to be adverb rather than an adjective?
That is, rather than specifying which whitespace, specify how you are

For example:

 Skip_Forward_Whitespace / Skip_Backward_Whitespace.

Or put it at the end:

 Skip_Whitespace_Forward / Skip_Whitespace_Backward

Or as you suggest, keep the common case short and modify only the rare one:

 Skip_Whitespace / Skip_Whitespace_[Back|Backward|Reverse]

I think all of these are slightly better than Skip_Prev_Whitespace,
which in turn is indeed much better than Recede_Whitespace.


View raw message