lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <mar...@rectangular.com>
Subject Re: [lucy-dev] Clownfish String API
Date Fri, 23 Oct 2015 16:01:58 GMT
On Thu, Oct 22, 2015 at 3:13 PM, Nathan Kurz <nate@verse.com> wrote:

> Perhaps consider the modifier to be adverb rather than an adjective?
> That is, rather than specifying which whitespace, specify how you are
> skipping.
>
> For example:
>
>  Skip_Forward_Whitespace / Skip_Backward_Whitespace.
>
> Or put it at the end:
>
>  Skip_Whitespace_Forward / Skip_Whitespace_Backward
>
> Or as you suggest, keep the common case short and modify only the rare one:
>
>  Skip_Whitespace / Skip_Whitespace_[Back|Backward|Reverse]

Thanks for the fresh perspective, Nate!  I'm fine with any of these;
if I were to pick one combo it would be
`Skip_Whitespace`/`Skip_Whitespace_Back`.

Marvin Humphrey

Mime
View raw message