lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <mar...@rectangular.com>
Subject Re: [lucy-dev] KinoSearch and perl 5.16
Date Sun, 15 Apr 2012 22:52:51 GMT
On Sun, Apr 15, 2012 at 11:16 AM,  <webmasters@ctosonline.org> wrote:
> I know Lucy has supplanted KinoSearch, but is it possible to make new
> releases of KinoSearch and KinoSearch1, for compatibility with perl 5.16?  I
> believe the only change necessary is the removal of the croak from the
> vtable destructor.

I've now uploaded KinoSearch 0.314 to CPAN, which passes tests under Perl
5.15.9 on my system.

Version 0.314 also adds the following near the top of every POD block:

    =head1 DEPRECATED

    The KinoSearch code base has been assimilated by the Apache L<Lucy>
    project.  The "KinoSearch" namespace has been deprecated, but development
    continues under our new name at our new home: L<http://lucy.apache.org/>

It is not necessary to upload a new version of KinoSearch1, as that distro
doesn't have new problems with recent Perls.

Thanks again for your help with the object destruction issues, and may you
and the other Perl 5 porters have a smooth release cycle with 5.16.0.

Marvin Humphrey

Mime
View raw message