lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Wellnhofer <wellnho...@aevum.de>
Subject Re: [lucy-dev] Build support classes for C extensions
Date Thu, 05 Apr 2012 18:45:17 GMT
On 05/04/2012 20:26, Nick Wellnhofer wrote:
> On 05/04/2012 18:35, Marvin Humphrey wrote:
>> On a related note, I would suggest that we rename
>> $clownfish_params{cf_include_dirs} to $clownfish_params{include}.
>>
>> * The need for the "cf_" prefix is not strong because the param is nested
>> within "clownfish_params". (Things would be different if we were adding
>> top-level M::B params).
>
> My first choice was 'include_dirs'. I only added the 'cf_' prefix to
> avoid confusion with the 'include_dirs' parameter of M::B. Using only
> 'include' is OK with me.

Thinking more about it, maybe we should find a better name than 
'include_dir' to use throughout Clownfish. It is ambigious, and it 
usually means that you include a file verbatim at a specific place in 
another file, which isn't what Clownfish actually does.

Nick

Mime
View raw message