lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <>
Subject [lucy-dev] Parse::RecDescent 1.96.0 vs. 1.94
Date Thu, 03 Nov 2011 02:01:50 GMT
On Tue, Nov 01, 2011 at 10:15:09AM -0700, Chris Hostetter wrote:
> 1) During both invokations of "perl Build.PL" I got the following 
> warning about needing a version of Parse::RecDescent that i already 
> had...
> --BEGIN--
> Checking prerequisites...
>   build_requires:
>     !  Parse::RecDescent (1.96.0) is installed, but we need version >= 1.94
> ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
> of the modules indicated above before proceeding with this installation
> --END--

Remember how I made a big fuss over naming Lucy's initial release "0.1.0" and
not "0.1"?  Parse::RecDescent has just illustrated why you really, really don't
want to mix X.Y and X.Y.Z version numbers for your CPAN distro.

In Perl, the X.Y.Z version number 1.96.0 numifies as the floating point value
1.096000.  1.096000 is less than 1.94.  :P  

There's nothing we can do about this.  It's a problem with Parse::RecDescent.

Mercifully, the problem will go away once we get to Lucy 0.3.0, since
Parse::RecDescent is no longer a Lucy dependency on trunk.

Marvin Humphrey

View raw message