lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <>
Subject Re: [lucy-dev] LockFreeRegistry CPAN testers failures
Date Fri, 10 Jun 2011 00:25:48 GMT
On Thu, Jun 09, 2011 at 04:34:57PM -0700, Marvin Humphrey wrote:
> I've tried to duplicate the problem using both the stock threaded perl 5.10.0
> that ships with Snow Leopard and a custom compiled perl 5.12.2 ("perl -V"
> output below my sig).  In both cases, the LockFreeRegistry test passes.  It
> also runs clean under Valgrind.

The Valgrind assertion above was inaccurate.

Valgrind for OS X appears to special-case the system Perl (/usr/bin/perl) and
ignore errors.  It exits clean, but it also doesn't detect errors.  I couldn't
even make Valgrind detect a blatant NULL-pointer deref intentionally inserted
into a test case.

And then I had actually forgotten to run the Valgrind test with the
custom-compiled Perl 5.12.2.  Duh. :p  When I run it now, it hangs.  No
errors, but the process eventually drops to 0 CPU and has to be killed.

So we don't actually have Valgrind data.  However, that doesn't change my
recommendation -- I still think we should disable the test except under

Marvin Humphrey

View raw message