lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Karman <>
Subject Re: [lucy-dev] Three class name changes
Date Sat, 02 Apr 2011 12:25:45 GMT
Marvin Humphrey wrote on 3/31/11 7:41 PM:

> The first change is to move LucyX::Simple to Lucy::Simple.


> The second change is to rename Lucy::Search::Compiler to
> Lucy::Search::Investigation, "A Query applied to a specific collection of
> documents."  With this change, each Query-Compiler-Matcher trio will become a
> Query-Investigation-Matcher trio instead.  I know that Nate would prefer to
> eliminate the middle stage entirely, creating Query-Matcher pairs.  The name
> change to Investigation is not meant to prejudice the decision to zap or not
> to zap, which is too involved to tackle prior to the 0.1.0-incubating release.

Investigation seems a little awkward as a name. The docs for the Compiler class say:

 "The purpose of the Compiler class is to take a specification in the form of a
Query object and compile a Matcher object that can do real work."

What's wrong with Compiler? It compiles a Matcher. MatchMaker? Investigation is
a kind of a passive noun. Investigator?

If this sounds like bike-shedding forgive me. I guess I just don't see the
problem with Compiler.

> The last change is to rename some XXXXXScorer classes to XXXXXMatcher, e.g.
> ANDScorer -> ANDMatcher.  Nearly all of these classes are private.  Their
> names should have been changed some time ago when we eliminated Scorer in
> favor of Matcher.  Better late than never.


Peter Karman  .  .

View raw message