lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <>
Subject Re: [lucy-dev] Three class name changes
Date Thu, 07 Apr 2011 23:17:54 GMT
On Thu, Apr 07, 2011 at 08:42:57AM -0500, Peter Karman wrote:
> I think the goal is a 0.1.0 release. Don't let the perfect become the
> enemy of the good. If the current class naming for Match/Compiler/Query
> is poor, but functioning, let's kick it down the road in favor of a
> re-design, as Nate suggests. 

While in my opinion renaming Compiler would have been a harmless incremental
improvement, with consensus proving elusive it's not important enough for me
to flog it forward.

I think we all agree that we should not block the 0.1.0 release holding out
for a double-rainbow solution to this long-standing problem.  
However, I'm willing to invest some time mulling over Nate's last email and
exploring how we might implement his suggestions.  Subtractive contributions
are valuable and rare.  

Marvin Humphrey

View raw message