lucy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marvin Humphrey <>
Subject [lucy-dev] Make Clownfish compiler unaware of Lucy
Date Sat, 30 Oct 2010 22:45:50 GMT

As I've been working on the transition to the "Lucy" namespace, I've been
coming across symbols such as KINO_INCREF and KINO_THROW, which logically
would now become LUCY_INCREF and LUCY_THROW.  However, INCREF() and THROW()
belong to Lucy::Object::Obj and Lucy::Object::Err respectively, and those
really don't belong under Lucy at all.  

The Clownfish compiler has to know about INCREF() and THROW(), but it
shouldn't know anything about Lucy, the search engine library.  Ultimately,
Obj and Err probably should move somewhere like Clownfish::Obj and
Clownfish::Err -- and the compiler should be renamed to ClownFishC, CFC, or
something like that.  ClownFishC would be aware of classes under Clownfish,
but oblivious of classes under Lucy.

To banish Lucy symbols from the Clownfish compiler, I think for now we should
rename symbols such as THROW to use CFISH_ (or possibly CF_) as a prefix
instead of LUCY_.

Very little of this stuff is public yet, but we'll have to expose more of it
when we publish a C API.  I think it would be good to start experimenting now.

Marvin Humphrey

View raw message