lucenenet-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeroen Lauwers <Jeroen.Lauw...@CTLO.NET>
Subject Inconsistent results
Date Fri, 28 Apr 2017 08:37:44 GMT
Dear all,

I've been seeing strange behavior with facets (but it may be a more general issue).

Steps:

1.       I created an index in an existing windows forms application. (indexing app)

2.       Next I created a new win forms project (client app) and got, in some cases, more
results than expected.
Code retrieving facets:
Lucene.Net.Facet.FacetsConfig facetConfig = new Lucene.Net.Facet.FacetsConfig();
facetConfig.SetRequireDimCount("Author", true);
Lucene.Net.Search.IndexSearcher searcher = new Lucene.Net.Search.IndexSearcher(reader);
Lucene.Net.Store.SimpleFSDirectory tFsd = new Lucene.Net.Store.SimpleFSDirectory(new System.IO.DirectoryInfo(taxoDir));
Lucene.Net.Facet.Taxonomy.Directory.DirectoryTaxonomyReader tReader = new Lucene.Net.Facet.Taxonomy.Directory.DirectoryTaxonomyReader(tFsd);
Lucene.Net.Facet.FacetsCollector fc = new Lucene.Net.Facet.FacetsCollector();
Lucene.Net.Facet.FacetsCollector.Search(searcher, Lucene.Net.Search.TermQuery(new Lucene.Net.Index.Term("aut",
"PAUG_"), int.MaxValue, fc);
Lucene.Net.Facet.Facets fs = new Lucene.Net.Facet.Taxonomy.FastTaxonomyFacetCounts(tReader,
facetConfig, fc);
Lucene.Net.Facet.FacetResult result = fs.GetTopChildren(int.MaxValue, "Author");


3.       If I ran the exact same retrieval code (and exact same index-dir) in the existing
indexing app, all counts where perfect.


4.       Eventually I found that unchecking "Prefer 32-bit" in the build settings solved the
problem for the client app. (In the indexing app this was also unchecked)



5.       I experienced the same problems in a ASP.NET app (also retrieval app), but in that
case I couldn't uncheck "Prefer 32-bit" because this is not an executable. So the issue remains.


My question now is if this "normal" behavior?
Should there be a difference between 32-bit, 64-bit, ... for indexes?

Jeroen

p.s. I downloaded the latest version from github (27/04/2017)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message