lucenenet-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prescott Nasser <geobmx...@hotmail.com>
Subject RE: ICU4NET.dll problem
Date Thu, 24 Nov 2016 19:16:50 GMT
Adding Peter as I don't think he's part of the mailing list

-----Original Message-----
From: Roethinger, Alexander [mailto:aroethinger@affili.net] 
Sent: Thursday, November 24, 2016 11:15 AM
To: user@lucenenet.apache.org
Subject: AW: ICU4NET.dll problem

Hi Peter,

this is a known issue which is already being addressed.
For the time being, a solution that worked for me was to remove the references to ICU4NET
and ICU4NET.Extensions from my project and delete the file links to the accompanying DLLs.

Your code will still compile and run as long as you don't reference the Thai Analyzer in Lucene.Net.Analysis.Common.
Then just deploy your code to the Webserver and it will work without the error message.
Please be aware that this is only a workaround.

Cheers
Alexander

-----Urspr├╝ngliche Nachricht-----
Von: Peter Petkani─Ź [mailto:crunckles@gmail.com] 
Gesendet: Donnerstag, 24. November 2016 12:49
An: user@lucenenet.apache.org
Betreff: ICU4NET.dll problem

Hello Lucene.net developers and community,

I have an MVC ASP.NET web app that will be hosted on local computer using IIS 7. Three Lucene.Net
projects are included in project -> Core, QueryParser (as it is a port from 3.0.3), Analysis.Common.
I tried using both libraries from MyGet and compiled source code from git. When I am running
source of app in VS 2015 everything is working just fine. But after publishing to IIS I am
getting error "Could not load file or assembly 'ICU4NET.DLL' or one of its dependencies. The
specified module could not be found.". I have been trying to resolve this issue, but without
any success.
Also before, I was getting an error "Could not load file or assembly 'ICU4NET' or one of its
dependencies. An attempt was made to load a program with an incorrect format." but I got it
resolved by enabling 32-bit applications in IIS. So yeah, can there be any unresolved problems
with platform mismatch? Or problem is somewhere else?

Thank you for your help.


Peter.
Mime
View raw message