lucenenet-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Garski <mgar...@myspace.com>
Subject RE: Indexing Error:The process cannot access the file '...._24va.cfs' because it is being used by another process.
Date Fri, 13 Jun 2008 18:30:42 GMT
If this is occurring when you are creating an index that is not currently being searched it
could be:

1) Another process is accessing the file.  I've seen disk defragmenting tools do that.

2) Do you have more than one instance of an IndexWriter?  The IndexWriter class is thread-safe
internally to allow multiple threads to add documents to it.  From my experience however I
would dissuade anyone from doing that on a high load system as the locking performed internally
will cause a bottleneck.

Or it could be something altogether different...  Anyone else have any ideas?

Michael

-----Original Message-----
From: Soormasher Singh [mailto:soormasher@yahoo.com] 
Sent: Friday, June 13, 2008 11:17 AM
To: lucene-net-user@incubator.apache.org
Subject: Re: Indexing Error:The process cannot access the file '...._24va.cfs' because it
is being used by another process.

This is occurring on the search side. I just have one physical index. When adding items to
index, the same index is being concurrently searched as well. 
But the problem occurs when I'm trying to do a full index as well at a location where there
are no searches being performed. 
Is there a fix for this?

Thanks! 


----- Original Message ----
From: Michael Garski <mgarski@myspace.com>
To: lucene-net-user@incubator.apache.org
Sent: Friday, June 13, 2008 11:57:02 AM
Subject: RE: Indexing Error:The process cannot access the file '...._24va.cfs' because it
is being used by another process.

Are you indexing and searching the same physical index? Is this occurring on the search or
index side? I would encounter that error in 1.9 when Lucene would merge segments and attempt
to delete the old one.  Lucene will attempt to delete a segment after it has merged and if
it fails, it will save the segment file name in the 'deletable' file and attempt to perform
the delete at a later merge.

Michael



-----Original Message-----
From: Soormasher Singh [mailto:soormasher@yahoo.com] 
Sent: Friday, June 13, 2008 7:50 AM
To: lucene-net-user@incubator.apache.org
Subject: Indexing Error:The process cannot access the file '...._24va.cfs' because it is being
used by another process.

MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="0-29666110-1213368585=:28926"

--0-29666110-1213368585=:28926
Content-Type: text/plain; charset=us-ascii

I used to get this error, or another variation of this error "The process cannot access the
file '..._28dv.cfs' because it is being used by another process."
occasionally. I'm getting this error very frequently now, almost every other time I do incremental
index or full indexing. It's driving me crazy and I can't really seem to find a fix for this.


Someone please help! I'm using Lucene 1.9 and due to some constraints, I can't really upgrade
to 2.1 version. I can make changes to 1.9 version code if there are any identifiable bugs.


An interesting thing I've noticed is that when I run the indexing process from within Visual
Studio Environment (Using NUnit), I don't get this error. It's only when I run the indexing
operation as a service or a console application that I get these errors. 

Someone please help!

Thanks! 


      
--0-29666110-1213368585=:28926
Content-Type: text/html; charset=us-ascii

<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div
style="font-family:times new roman, new york, times, serif;font-size:12pt"><div>I
used to get this error, or another variation of this error "The process cannot access the
file '..._28dv.cfs' because it is being used by another process."<br>occasionally. I'm
getting this error very frequently now, almost every other time I do incremental index or
full indexing. It's driving me crazy and I can't really seem to find a fix for this. <br><br>Someone
please help! I'm using Lucene 1.9 and due to some constraints, I can't really upgrade to 2.1
version. I can make changes to 1.9 version code if there are any identifiable bugs. <br><br>An
interesting thing I've noticed is that when I run the indexing process from within Visual
Studio Environment (Using NUnit), I don't get this error. It's only when I run the indexing
operation as a service or a console application that I get
these errors. <br><br>Someone please help!<br><br>Thanks! <br><br></div></div><br>



      </body></html>
--0-29666110-1213368585=:28926--



      
Mime
View raw message