lucenenet-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nightowl...@apache.org
Subject [lucenenet] 02/12: build.ps1: Removed functions that install the .NET Core 1.0 SDK
Date Thu, 11 Jul 2019 15:42:57 GMT
This is an automated email from the ASF dual-hosted git repository.

nightowl888 pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/lucenenet.git

commit dcc15dd7bf7e1926c20b04a41ff84a775a7ec113
Author: Shad Storhaug <shad@shadstorhaug.com>
AuthorDate: Thu Jul 11 14:43:12 2019 +0700

    build.ps1: Removed functions that install the .NET Core 1.0 SDK
---
 build/build.ps1 | 28 ----------------------------
 1 file changed, 28 deletions(-)

diff --git a/build/build.ps1 b/build/build.ps1
index c03fee6..30a46f5 100644
--- a/build/build.ps1
+++ b/build/build.ps1
@@ -85,34 +85,6 @@ task InstallSDK -description "This task makes sure the correct SDK version
is in
 	}
 }
 
-task InstallSDK2IfRequired -description "This task installs the .NET Core 2.x SDK (required
for testing under .NET Core 2.0 or .NET Framework)" {
-	Write-Host "##teamcity[progressMessage 'Installing SDK']"
-	# netcoreapp1.0 requires the .NET Core SDK 2.0 or there is an 'illegal characters in path'
error
-	#if ($frameworks_to_test.Contains("netcoreapp2.") -or $frameworks_to_test.Contains("net45"))
{
-		Invoke-Task InstallSDK
-	#}
-}
-
-task InstallSDK1IfRequired -description "This task installs the .NET Core 1.x SDK (required
for testing under .NET Core 1.0)" -ContinueOnError {
-	Write-Host "##teamcity[progressMessage 'Installing SDK 1.x']"
-	if ($frameworks_to_test.Contains("netcoreapp1.")) {
-
-		# Make sure framework for .NET Core 1.1.14 is available
-		$installed = Is-Sdk-Version-Installed '1.1.14'
-		if (!$installed) {
-			Write-Host "Requires SDK version 1.1.14, installing..." -ForegroundColor Red
-			Invoke-Expression "$base_directory\build\dotnet-install.ps1 -Version 1.1.14"
-		}
-
-		# Safety check - this should never happen
-		& where.exe dotnet.exe
-
-		if ($LASTEXITCODE -ne 0) {
-			throw "Could not find dotnet CLI in PATH. Please install the .NET Core 1.1.14 SDK."
-		}
-	}
-}
-
 task Init -depends InstallSDK, UpdateLocalSDKVersion -description "This task makes sure the
build environment is correctly setup" {
 	#Update TeamCity or MyGet with packageVersion
 	Write-Output "##teamcity[buildNumber '$packageVersion']"


Mime
View raw message