lucenenet-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nightowl...@apache.org
Subject [1/2] lucenenet git commit: build/build.ps1: Installing .NET Core 2.0 SDK during 1.0 testing due to 'illegal characters in path error' that began when not installing both SDKs for that task
Date Sun, 17 Sep 2017 20:18:18 GMT
Repository: lucenenet
Updated Branches:
  refs/heads/master 537055a73 -> 06b676ec8


build/build.ps1: Installing .NET Core 2.0 SDK during 1.0 testing due to 'illegal characters
in path error' that began when not installing both SDKs for that task


Project: http://git-wip-us.apache.org/repos/asf/lucenenet/repo
Commit: http://git-wip-us.apache.org/repos/asf/lucenenet/commit/9e47928d
Tree: http://git-wip-us.apache.org/repos/asf/lucenenet/tree/9e47928d
Diff: http://git-wip-us.apache.org/repos/asf/lucenenet/diff/9e47928d

Branch: refs/heads/master
Commit: 9e47928de4e8e9ad0ec9f050f6c504e05bcbb2c2
Parents: 537055a
Author: Shad Storhaug <shad@shadstorhaug.com>
Authored: Mon Sep 18 02:57:53 2017 +0700
Committer: Shad Storhaug <shad@shadstorhaug.com>
Committed: Mon Sep 18 02:57:53 2017 +0700

----------------------------------------------------------------------
 build/build.ps1 | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/lucenenet/blob/9e47928d/build/build.ps1
----------------------------------------------------------------------
diff --git a/build/build.ps1 b/build/build.ps1
index 205aeaa..db954c3 100644
--- a/build/build.ps1
+++ b/build/build.ps1
@@ -88,9 +88,10 @@ task InstallSDK -description "This task makes sure the correct SDK version
is in
 
 task InstallSDK2IfRequired -description "This task installs the .NET Core 2.x SDK (required
for testing under .NET Core 2.0 or .NET Framework)" {
 	Write-Host "##teamcity[progressMessage 'Installing SDK']"
-	if ($frameworks_to_test.Contains("netcoreapp2.") -or $frameworks_to_test.Contains("net45"))
{
+	# netcoreapp1.0 requires the .NET Core SDK 2.0 or there is an 'illegal characters in path'
error
+	#if ($frameworks_to_test.Contains("netcoreapp2.") -or $frameworks_to_test.Contains("net45"))
{
 		Invoke-Task InstallSDK
-	}
+	#}
 }
 
 task InstallSDK1IfRequired -description "This task installs the .NET Core 1.x SDK (required
for testing under .NET Core 1.0)" {


Mime
View raw message