lucenenet-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nightowl...@apache.org
Subject [2/2] lucenenet git commit: build/build.ps1: Failing the build isn't working, for now, removing that extra script
Date Sun, 10 Sep 2017 15:01:40 GMT
build/build.ps1: Failing the build isn't working, for now, removing that extra script


Project: http://git-wip-us.apache.org/repos/asf/lucenenet/repo
Commit: http://git-wip-us.apache.org/repos/asf/lucenenet/commit/496b1401
Tree: http://git-wip-us.apache.org/repos/asf/lucenenet/tree/496b1401
Diff: http://git-wip-us.apache.org/repos/asf/lucenenet/diff/496b1401

Branch: refs/heads/master
Commit: 496b14016270a7a6211cf7fc233bee6a782ccfd4
Parents: c02a98d
Author: Shad Storhaug <shad@shadstorhaug.com>
Authored: Sun Sep 10 21:58:08 2017 +0700
Committer: Shad Storhaug <shad@shadstorhaug.com>
Committed: Sun Sep 10 22:01:05 2017 +0700

----------------------------------------------------------------------
 build/build.ps1 | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/lucenenet/blob/496b1401/build/build.ps1
----------------------------------------------------------------------
diff --git a/build/build.ps1 b/build/build.ps1
index c303a01..4e9271a 100644
--- a/build/build.ps1
+++ b/build/build.ps1
@@ -72,20 +72,14 @@ task InstallSDK -description "This task makes sure the correct SDK version
is in
 	if (!$sdkVersion.Equals("1.0.4")) {
 		Write-Host "Require SDK version 1.0.4, installing..." -ForegroundColor Red
 		#Install the correct version of the .NET SDK for this build
-	    $success = Invoke-Expression "$base_directory\build\dotnet-install.ps1 -Version 1.0.5;$?"
-		if (-not $success) {
-			throw "The .NET Core 1.0.4 SDK failed to install."
-		}
+		Invoke-Expression "$base_directory\build\dotnet-install.ps1 -Version 1.0.4"
 	}
 
 	# Make sure framework for .NET Core 2.0.0 is available
 	if (!$sdkVersion.Equals("2.0.0")) {
 		Write-Host "Require SDK version 2.0.0, installing..." -ForegroundColor Red
 		#Install the correct version of the .NET SDK for this build
-	    $success = Invoke-Expression "$base_directory\build\dotnet-install.ps1 -Version 2.0.0;$?"
-		if (-not $success) {
-			throw "The .NET Core 2.0.0 SDK failed to install."
-		}
+		Invoke-Expression "$base_directory\build\dotnet-install.ps1 -Version 2.0.0"
 	}
 
 	# Safety check - this should never happen


Mime
View raw message