lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörn Franke <jornfra...@gmail.com>
Subject Re: Solr 8.4.0 Cloud Graph is not shown due to CSP
Date Wed, 08 Jan 2020 09:48:39 GMT
I have to admit it was the cache. Sorry I believed I deleted it. Thanks for the efforts and
testing ! I will update the Jira.

> Am 07.01.2020 um 22:14 schrieb Jörn Franke <jornfranke@gmail.com>:
> 
> 
> here you go:
> https://issues.apache.org/jira/browse/SOLR-14176
> 
> a detailed screenshot of the message can be made tomorrow, but it looks pretty much to
CSP to me - i have seen others with other applications using CSP.
> 
>> On Tue, Jan 7, 2020 at 6:45 PM Kevin Risden <krisden@apache.org> wrote:
>> So this is caused by SOLR-13982 [1] and specifically SOLR-13987 [2]. Can
>> you open a new Jira specifically for this? It would be great if you could
>> capture from Chrome Dev Tools (or Firefox) the error message around what
>> specifically CSP is complaining about.
>> 
>> The other thing to ensure is that you force refresh the UI to make sure
>> nothing is cached. Idk if that is in play here but doesn't hurt.
>> 
>> [1] https://issues.apache.org/jira/browse/SOLR-13982
>> [2] https://issues.apache.org/jira/browse/SOLR-13987
>> 
>> Kevin Risden
>> 
>> On Tue, Jan 7, 2020, 11:15 Jörn Franke <jornfranke@gmail.com> wrote:
>> 
>> > Dear all,
>> >
>> > I noted that in Solr Cloud 8.4.0 the graph is not shown due to
>> > Content-Security-Policy. Apparently it violates unsafe-eval.
>> > It is a minor UI thing, but should I create an issue to that one? Maybe it
>> > is rather easy to avoid in the source code of the admin page?
>> >
>> > Thank you.
>> >
>> > Best regards
>> >
>> >
>> >

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message