lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Osiek <baos...@gmail.com>
Subject Re: Solr - zkRun problem
Date Thu, 05 Sep 2019 13:28:32 GMT
In order to persist docker container files into its host filesystem you
need to link both by -v parameter when starting the container. As you said
the problem  emerges only when restarting this would be my guess.

Regards,
Bruno

On Thu, Sep 5, 2019 at 1:19 AM Tamás Barta <bartatamas@gmail.com> wrote:

> Hi,
>
> I use Solr Cloud with 3 ZK nodes in production and it is good.
>
> Now I try to create a "simple" Solr docker container in a test environment.
> I don't want to create ZK nodes too so I run solr with the -DzkRun
> parameter to start embedded Zookeeper. After it start I uploaded my
> configuration to ZK and created a collection in the Solr Admin UI based on
> this uploaded config. So far so good.
>
> The problem occurs when I restart Solr, the log:
>
> o.a.s.c.ZkController bootstrapping config for 1 cores into ZooKeeper using
> solr.xml from /var/solr/data
> o.a.s.c.ZkController Uploading directory
> /var/solr/data/users_shard1_replica_n1/conf with name
> users_shard1_replica_n1 for SolrCore users_shard1_replica_n1
> o.a.s.c.ZkContainer  => java.io.IOException: Path
> /var/solr/data/users_shard1_replica_n1/conf does not exist
>
> It seems it tries to upload a "conf" directory into ZK at bootstrap. It is
> not ok as the collection is created based on configuration in ZK. In the
> core.properties there is the line:
>
> collection.configName=myconfig
>
> But it seems it is ignored. What is the problem here? May I do something
> wrong?
>
> Thanks, Tamás
>
-- 
Enviado de dispositivo móvel.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message