lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paras Lehana <paras.leh...@indiamart.com>
Subject Re: Solr status showing wrong data
Date Tue, 24 Sep 2019 05:36:04 GMT
Hi, Jayadevan

2 GB is not 11.8% of 3.8 GB.


This is an interesting observation. I also confirmed the ambiguity on my
machine:

 "memory":"4 GB (%26.3) of 7.7 GB"


My JVM heap config is:

-Xms8g -Xmx16g


So, this 26.3% could be of the* max available heap space* *(*)* allocated
to solr process (java). Since, current memory usage is under Xms (8G),
current heap size is correctly reported. But it seems that the percentage
usage is being reported as per the possible max heap space that could be
allocated to solr (16G).

Thus, can I ask you to share your JVM heap config or confirm the maths with
that yourself? *I guess you Xms is 4G while Xmx is probably around 16G. *

PS: I also tried to inspect the source code of solr script in bin to find
exactly what "memory" key reports and this is what I could find:

 run_tool status -solr "$SOLR_URL_SCHEME://$SOLR_TOOL_HOST:$port/solr


And I could not go past this. Maybe someone who had gone deeper into the
source code could confirm about* (*)*.

On Tue, 24 Sep 2019 at 09:50, Jayadevan Maymala <jayadevan@ftltechsys.com>
wrote:

> Hi,
>
> I just tried service solr status on my CentOS machine. It gave this output
> for memory utilization -
>   "memory":"2 GB (%11.8) of 3.8 GB",
> 2 GB is not 11.8% of 3.8 GB. Is it that I am not understanding the output
> correctly?
>
> Solr Version - 7.3.0
> CentOS  7.7
>
> Regards,
> Jayadevan
>


-- 
-- 
Regards,

*Paras Lehana* [65871]
Software Programmer, Auto-Suggest,
IndiaMART Intermesh Ltd.

8th Floor, Tower A, Advant-Navis Business Park, Sector 142,
Noida, UP, IN - 201303

Mob.: +91-9560911996
Work: 01203916600 | Extn:  *8173*

-- 
IMPORTANT: 
NEVER share your IndiaMART OTP/ Password with anyone.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message