lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Solr 8.2.0 having issue with ZooKeeper 3.5.5
Date Thu, 01 Aug 2019 10:58:35 GMT
The issue was only cosmetic in the sense that the admin UI was the only thing that was affected,
not other Solr functions when I was working on this.

Please check a few things:

1> be absolutely sure that you’ve added this in all your zoo.cfg files

2> the example on the ZooKeeper website has spaces, could you try that just to cover all
bases? Stranger things have happened…

4lw.commands.whitelist=mntr, ruok, conf
not
4lw.commands.whitelist=mntr,ruok,conf

3> if <1> and <2> don’t work, what happens if you start your ZooKeepers with

-Dzookeeper.4lw.commands.whitelist=….

If it’s not <1> or <2>, please raise a JIRA.

Best,
Erick

Also, see: SOLR-13502 (no work has been done on this yet)

> On Aug 1, 2019, at 6:05 AM, Jörn Franke <jornfranke@gmail.com> wrote:
> 
> For me:
> * ZK stand-alone mode - no issues
> * ZK Ensemble - it seems to be only a cosmetic issue in the Admin UI (I see the same
error message), but aside this Solr is working fine 
> 
> 
> 
>> Am 01.08.2019 um 12:02 schrieb Zheng Lin Edwin Yeo <edwinyeozl@gmail.com>:
>> 
>> Hi Jörn,
>> Thank you for your reply.
>> 
>> I have encountered problem when I tried to create a collection with this
>> new version of ZooKeeper. You can find my Solr log file here:
>> https://drive.google.com/open?id=1qkMLTRJ4eDSFwbqr15wSqjbg4dJV-bGN
>> 
>> Does it work perfectly at your side for creating collections and indexing
>> even when running ZooKeeper ensemble?
>> 
>> Regards,
>> Edwin
>> 
>> 
>>> On Thu, 1 Aug 2019 at 17:39, Jörn Franke <jornfranke@gmail.com> wrote:
>>> 
>>> I confirm the issue.
>>> 
>>> Interestingly it does not happen with ZK standalone, but only in a ZK
>>> Ensemble.
>>> 
>>> It seems to be mainly cosmetic in the admin UI because Solr appears to
>>> function normally.
>>> 
>>>> Am 01.08.2019 um 03:31 schrieb Zheng Lin Edwin Yeo <edwinyeozl@gmail.com
>>>> :
>>>> 
>>>> Yes. You can get my full solr.log from the link below. The error is there
>>>> when I tried to create collection1 (around line 170 to 300) .
>>>> 
>>>> https://drive.google.com/open?id=1qkMLTRJ4eDSFwbqr15wSqjbg4dJV-bGN
>>>> 
>>>> Regards,
>>>> Edwin
>>>> 
>>>> 
>>>>> On Wed, 31 Jul 2019 at 18:39, Jan Høydahl <jan.asf@cominvent.com>
>>> wrote:
>>>>> 
>>>>> Please look for the full log file solr.log in your Solr server, and
>>> share
>>>>> it via some file sharing service or gist or similar for us to be able
to
>>>>> decipher the collection create error.
>>>>> 
>>>>> --
>>>>> Jan Høydahl, search solution architect
>>>>> Cominvent AS - www.cominvent.com
>>>>> 
>>>>>> 31. jul. 2019 kl. 08:33 skrev Zheng Lin Edwin Yeo <
>>> edwinyeozl@gmail.com
>>>>>> :
>>>>>> 
>>>>>> Hi,
>>>>>> 
>>>>>> Regarding the issue, I have tried to put the following in zoo.cfg
under
>>>>>> ZooKeeper:
>>>>>> 4lw.commands.whitelist=mntr,conf,ruok
>>>>>> 
>>>>>> But it is still showing this error.
>>>>>> *"Errors: - membership: Check 4lq.commands.whitelist setting in
>>> zookeeper
>>>>>> configuration file."*
>>>>>> 
>>>>>> As I am using SolrCloud, the collection config can still be loaded
to
>>>>>> ZooKeeper as per normal. But if I tried to create a collection, I
will
>>>>> get
>>>>>> the following error:
>>>>>> 
>>>>>> {
>>>>>> "responseHeader":{
>>>>>> "status":400,
>>>>>> "QTime":686},
>>>>>> "failure":{
>>>>>> "192.168.1.2:8983
>>>>> _solr":"org.apache.solr.client.solrj.SolrServerException:IOException
>>>>>> occurred when talking to server at:http://192.168.1.2:8983/solr",
>>>>>> "192.168.1.2:8984
>>>>> _solr":"org.apache.solr.client.solrj.SolrServerException:IOException
>>>>>> occurred when talking to server at:http://192.168.1.2:8984/solr"},
>>>>>> "Operation create caused
>>>>>> 
>>>>> 
>>> exception:":"org.apache.solr.common.SolrException:org.apache.solr.common.SolrException:
>>>>>> Underlying core creation failed while creating collection:
>>> collection1",
>>>>>> "exception":{f
>>>>>> "msg":"Underlying core creation failed while creating collection:
>>>>>> collection1",
>>>>>> "rspCode":400},
>>>>>> "error":{
>>>>>> "metadata":[
>>>>>>   "error-class","org.apache.solr.common.SolrException",
>>>>>>   "root-error-class","org.apache.solr.common.SolrException"],
>>>>>> "msg":"Underlying core creation failed while creating collection:
>>>>>> collection1",
>>>>>> "code":400}}
>>>>>> 
>>>>>> Is there anything which I may have missed out?
>>>>>> 
>>>>>> Regards,
>>>>>> Edwin
>>>>>> 
>>>>>> On Tue, 30 Jul 2019 at 10:05, Zheng Lin Edwin Yeo <
>>> edwinyeozl@gmail.com>
>>>>>> wrote:
>>>>>> 
>>>>>>> Hi,
>>>>>>> 
>>>>>>> I am using the new Solr 8.2.0 with SolrCloud and external ZooKeeper
>>>>> 3.5.5.
>>>>>>> 
>>>>>>> However, after adding in the line under zoo.cfg
>>>>>>> *4lw.commands.whitelist=**
>>>>>>> 
>>>>>>> I get the error under Cloud -> ZK Status in Solr
>>>>>>> *"Errors: - membership: Check 4lq.commands.whitelist setting
in
>>>>> zookeeper
>>>>>>> configuration file."*
>>>>>>> 
>>>>>>> I have noticed that the issue is cause by adding the "conf" in
the
>>>>>>> whitelist. But if I do not add the "conf" to the whitelist, I
will get
>>>>> the
>>>>>>> following error:
>>>>>>> *"Errors: - conf is not executed because it is not in the whitelist.
>>>>> Check
>>>>>>> 4lw.commands.whitelist setting in zookeeper configuration file."*
>>>>>>> 
>>>>>>> What could be the issue that cause this error, and how can we
resolve
>>>>> it.
>>>>>>> 
>>>>>>> Thank you.
>>>>>>> 
>>>>>>> Regards,
>>>>>>> Edwin
>>>>>>> 
>>>>> 
>>>>> 
>>> 


Mime
View raw message