lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <>
Subject Re: What are the risk of running into "Unmap hack not supported on this platform"
Date Wed, 28 Aug 2019 19:08:48 GMT
On 8/27/2019 8:22 AM, Pushkar Raste wrote:
> I am trying to run Solr 4 on JDK11, although this version is not supported
> on JDK11 it seems to be working fine except for the error/exception "Unmap
> hack not supported on this platform".
> What the risks/downsides of running into this.

The first version of Solr that was qualified with Java 9 was Solr 7.0.0. 
  New Java versions did not work properly with older versions of Solr. 
Java 8 is as high as you can go with Solr 4.

Solr versions up through 4.7.x have a minimum Java version requirement 
of Java 6.  From 4.8.0 through 5.x, Java 7 is required as a minimum. 
Starting with Solr 6.0.0, the minimum requirement moved to Java 8.  When 
Solr 9.0.0 is released, its minimum requirement will be Java 11.

Right now, with Solr 8.x being the current version, Solr 7.x is only 
going to get major bugfixes, and there will be no updates at all to 
version 6.x and older.  The problem you're running into with Solr 4 on 
Java 11 will not be fixed.  If you want to run Java 11, you will need to 
upgrade to the latest Solr 7.x or 8.x.  Early 7.x versions would not 
work with Java 10 or later.


View raw message