lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Høydahl <jan....@cominvent.com>
Subject Re: Solr 8.2.0 having issue with ZooKeeper 3.5.5
Date Wed, 31 Jul 2019 10:39:25 GMT
Please look for the full log file solr.log in your Solr server, and share it via some file
sharing service or gist or similar for us to be able to decipher the collection create error.

--
Jan Høydahl, search solution architect
Cominvent AS - www.cominvent.com

> 31. jul. 2019 kl. 08:33 skrev Zheng Lin Edwin Yeo <edwinyeozl@gmail.com>:
> 
> Hi,
> 
> Regarding the issue, I have tried to put the following in zoo.cfg under
> ZooKeeper:
> 4lw.commands.whitelist=mntr,conf,ruok
> 
> But it is still showing this error.
> *"Errors: - membership: Check 4lq.commands.whitelist setting in zookeeper
> configuration file."*
> 
> As I am using SolrCloud, the collection config can still be loaded to
> ZooKeeper as per normal. But if I tried to create a collection, I will get
> the following error:
> 
> {
>  "responseHeader":{
>    "status":400,
>    "QTime":686},
>  "failure":{
>    "192.168.1.2:8983_solr":"org.apache.solr.client.solrj.SolrServerException:IOException
> occurred when talking to server at:http://192.168.1.2:8983/solr",
>    "192.168.1.2:8984_solr":"org.apache.solr.client.solrj.SolrServerException:IOException
> occurred when talking to server at:http://192.168.1.2:8984/solr"},
>  "Operation create caused
> exception:":"org.apache.solr.common.SolrException:org.apache.solr.common.SolrException:
> Underlying core creation failed while creating collection: collection1",
>  "exception":{f
>    "msg":"Underlying core creation failed while creating collection:
> collection1",
>    "rspCode":400},
>  "error":{
>    "metadata":[
>      "error-class","org.apache.solr.common.SolrException",
>      "root-error-class","org.apache.solr.common.SolrException"],
>    "msg":"Underlying core creation failed while creating collection:
> collection1",
>    "code":400}}
> 
> Is there anything which I may have missed out?
> 
> Regards,
> Edwin
> 
> On Tue, 30 Jul 2019 at 10:05, Zheng Lin Edwin Yeo <edwinyeozl@gmail.com>
> wrote:
> 
>> Hi,
>> 
>> I am using the new Solr 8.2.0 with SolrCloud and external ZooKeeper 3.5.5.
>> 
>> However, after adding in the line under zoo.cfg
>> *4lw.commands.whitelist=**
>> 
>> I get the error under Cloud -> ZK Status in Solr
>> *"Errors: - membership: Check 4lq.commands.whitelist setting in zookeeper
>> configuration file."*
>> 
>> I have noticed that the issue is cause by adding the "conf" in the
>> whitelist. But if I do not add the "conf" to the whitelist, I will get the
>> following error:
>> *"Errors: - conf is not executed because it is not in the whitelist. Check
>> 4lw.commands.whitelist setting in zookeeper configuration file."*
>> 
>> What could be the issue that cause this error, and how can we resolve it.
>> 
>> Thank you.
>> 
>> Regards,
>> Edwin
>> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message