lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Document Score seen in debug section and in main results section dont match
Date Tue, 12 Feb 2019 03:32:39 GMT
No workarounds that I know of, but I have to ask:
"Why do you care?". This feels like an XY problem.
You are saying that "X" doesn't work, in this case the
scores are different in the debug section. But this
implies that there is a problem "Y" that you're having.

What is "Y"? What is the problem that these differing
scores is germane to? Perhaps there's another approach
that'll work to solve "Y" other than scores.

Best,
Erick

On Mon, Feb 11, 2019 at 6:04 AM Baloo <asksearchdev@gmail.com> wrote:
>
> HI All,
>
> Currently I am migrating  Solr 6.4.2 to Solr 7.4.  We pass multiple boost
> queries (multiplicative boost queries, Solr's 'boost' parameter) to Solr
> with each query. We have migrated all our custom components and solr
> configurations to Solr 7.4.2 but during verification we have seen different
> score in debug section which is not matching with the score that we see when
> we return score field using fl parameter.
>
> After spending half of my day analysing issue I found similar issue is
> already open. Below issue is exactly same as what I am also observing with
> Solr 7.4.
>
> https://issues.apache.org/jira/browse/SOLR-13126
>
> Is there and solution/workaround available for this issue?
> or going back to Solr 7.2.1 is the only solution - As per comments in above
> issue (https://issues.apache.org/jira/browse/LUCENE-8099 these changes are
> not there in 7.2.1)
>
> Any help will be appreciated.
>
>
>
>
> --
> Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html

Mime
View raw message