lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Salvo Bonanno <salvob.l...@gmail.com>
Subject SolrCore Initialization Failure Error loading class 'solr.IntField'
Date Wed, 29 Aug 2018 07:27:06 GMT
Hello Everyone!

I have a strange problem, I'm trying to move an existing and working
configuration of Apache Solr from a server to another one.

The configuration is really simple since it's still incomplete, i've
just create the core and create a managed-schema.

The core is running flawlessy on the former server, but on the new
one, with the exactly same configutation, gives an Initialitation
Error.

[error]
corename: org.apache.solr.common.SolrException:org.apache.solr.common.SolrException:
Could not load conf for core corename: Can't load schema
/opt/solr/server/solr/corename/conf/managed-schema:  Plugin init
failure for [schema.xml] fieldType "long": Error loading class
'solr.IntPointField '

Please check your logs for more information
[/error]

Here's the snippet from the schema
[schema]
<fieldType name="int" class="solr.IntPointField"
positionIncrementGap="0" docValues="true" precisionStep="0"/>
   <field name="_version_" type="long" indexed="true" stored="false"/>
  <fieldType name="long" class="solr.IntPointField "
positionIncrementGap="0" docValues="true" precisionStep="0"/>
  <fieldType name="plongs" class="solr.LongPointField"
positionIncrementGap="0" docValues="true" precisionStep="0"/>
  <fieldType name="pdates" class="solr.DatePointField "
docValues="true" multiValued="true"/>
  <fieldType name="pdoubles" class="solr.DoublePointField  "
positionIncrementGap="0" docValues="true" precisionStep="0"/>
[/schema]

The schema contains the same fields on both server with the same
version of Solr but one works, the other one doesn't!

Other noticable differences is the java version... but I believe that
this shouldn't matter:

# NEW SERVER
solr-ypa solr]$ java -version
openjdk version "1.8.0_181"
OpenJDK Runtime Environment (build 1.8.0_181-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

# FORMER SERVER
[solr@localhost ~]$ java -version
openjdk version "1.8.0_161"
OpenJDK Runtime Environment (build 1.8.0_161-b14)
OpenJDK 64-Bit Server VM (build 25.161-b14, mixed mode)

Can someone gives me a hint? Thanks in advance

Mime
View raw message