lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duncan, Adam" <Adam.Dun...@nordstrom.com>
Subject Verifying autoscale events via History Api
Date Tue, 10 Jul 2018 20:46:00 GMT
Hi all,

We are trying to confirm that a Autoscaling ‘nodeAdded’ event triggers when a node joins
the cluster using the History Api.
We’ve added a node to the cluster but do not see any records in the Autoscale History endpoint.
As a side note, we had to manually create the .system collection. The history endpoint was
erroring with '.system collection does not exist'. So we created that collection manually.
The History Api no longer errors, but has no records
This is for solr 7.3.

Our trigger and listener were created as standard based on the solr documentation (below):
triggers:
{

     *   node_added_trigger:
{

        *   event: "nodeAdded",
        *   waitFor: 1,
        *   actions:
[

           *   {
              *   name: "compute_plan",
              *   class: "solr.ComputePlanAction",
},

           *   {
              *   name: "execute_plan",
              *   class: "solr.ExecutePlanAction",
},
],

        *   enabled: true,
}
},

  *   listeners:
{

     *   node_added_trigger.system:
{

        *   trigger: "node_added_trigger",
        *   afterAction: [ ],
        *   stage:
[

           *   "STARTED",
           *   "ABORTED",
           *   "SUCCEEDED",
           *   "FAILED",
           *   "BEFORE_ACTION",
           *   "AFTER_ACTION",
           *   "IGNORED",
],

        *   class: "org.apache.solr.cloud.autoscaling.SystemLogListener",
        *   beforeAction: [ ],
}
},

Any thoughts on why we’re not seeing any event history ?

Thanks!
Adam
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message