lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From turpentyne <turpent...@gmail.com>
Subject Solr 6.6.3 won't start - unrecognized vm option "UseParNewGC" - Java 10.0.1
Date Sat, 12 May 2018 21:02:31 GMT
Running into an issue beyond my experience level.


In Installed and started Solr 7.3. But, then I realized I need to use an
older 6.x version (for Drupal)

So, I installed Solr 6.6.3. But, it will not start.

The message I get is:

**Still not seeing Solr listening on 8983 after 180 seconds!*

*tail: /Applications/solr-6.6.3/server/logs/solr.log: No such file or
directory**

I get the same same result, whether I use *bin/solr start* or *sudo*.

The solr.log is definitely missing. But there is a Solr-8983-console.log.
This shows the message below:

**Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was
deprecated in version 9.0 and will likely be removed in a future release.*

*Unrecognized VM option 'UseParNewGC'*

*Error: Could not create the Java Virtual Machine.*

*Error: A fatal exception has occurred. Program will exit.**

Java -version displays as 10.0.1. This is a work computer with security
needs, and I believe I need to keep it as updated as possible:

**java version "10.0.1" 2018-04-17*

*Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)*

*Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)**

Also tried with Solr 6.6.3, 6.6.0 and 5.0.0 with same failure and log
message.

If relevant, I'm on a 2015 macbook pro, using high sierra 10.13.3

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message